Announcement

Collapse
1 of 2 < >

No iCloud Lock Discussion

There is no legitimate, feasible, solution for iCloud lock. We believe that iCloud lock is a GOOD THING overall and reduces theft. Any posts asking about circumventing iCloud lock will be deleted.
2 of 2 < >

Announcement

Welcome to the NEW iPad Rehab Forum! Everyone is welcome to read posts and learn for free. If you'd like to post your own question on the forum, please click "register" above or go here: http://forum.mendonipadrehab.com/register to enroll as a paid subscriber for $29/mo for unlimited access to our forum support and private signature failure section.
See more
See less

iPad Mini 4 Charges at Normal voltage until the device Boots

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iPad Mini 4 Charges at Normal voltage until the device Boots

    iPad Mini 4 Charges at Normal voltage/Amps until the device Boots pulling between 1.2-1.4A but soon as home screen appears it drops to zero A.

    The iPad came to us as it was "Dead" i tested usb with battery connected and without to check for charge port fail or maybe a "Tristar" (or equivalent ic), This had No effect pulling 0.00A. I Tested device with charged battery to see if there was a more serious problem, and device booted fine.

    I then changed the charge port as i have seen this alot with the air range and the mini's 3/4 and after the repair the device started to act normal, i.e plug in charger cable and there is a normal boot pattern with the device recognizing a cable being plugged in (prompt to boot) , however as soon as home menu appears it drops amps to zero.

    I have tested 3 batteries all act the same and i have checked with the battery disconnected and it boot loops as expected.

    I have also done a visual inspection of the board and i haven't seen anything unusual.

    I have no schematics and zxw is bare, am i right in thinking this could be a Tigress issue (or equivalent) as the device is recognizing both battery and lightning cables when plugged in? or the only other idea i had is battery data lines (gas gage?) are damaged but there are no missing or scorched components around or near battery terminal

    One thing i noticed is when the device is booted it no longer recognizes the lightning cable which does make me think maybe it could be Tristar? (i will check in morning to see if it is recognised in pc and not just the charger)

    If anyone Knows what Tristar/Tigress the Mini 4 uses or is compatible that would be greatly appreciated.

    Thanks in advance

    (i didn't know where to post this as no ipad section? sorry if in wrong place)





  • #2
    They use the same pmic as the iPad Air which also suffers this same problem, people on gsmforum have reported success in changing the pmic to resolve it. It may be a bad battery or battery current sense lines but every time iv seen it iv gone over all of those and always found it's the pmic.
    It depends if you see a lot of other shops work where it's possibly been screwed with befudd. Most of mine is direct from the customer so mostly the battery has been original and untouched.

    Comment


    • #3
      Thanks for reply crea2k I'll check that out, I'm not sure it's pmic as boots and stays on with charged battery behaving normally. I'm fairly new to this so excuse my ignorance, does pmic also control charging while on? (Ie talking to battery and tigress) I always thought it distrbuted power to the smaller Ic's?

      Comment


      • #4
        The PMIC generates the baby voltage from VC_Main

        Comment


        • #5
          It does distribute power to the smaller ics, but if the smaller ics arnt told to do their job they won't do. If you look on the schematic on the pmic is a charge current in line called battery sns, if this goes wrong it really doesn't like charging. You can try another battery and also check this line is intact, but guy's on gsmforum have reported success in changing it, so if you've tried everything else that's what it'll be.
          without the go ahead from the pmic charging won't happen.

          Comment


          • #6
            That makes sense i will check the sns line thanks for the input. I'm definitely going to read up on the pmic i had no idea they can interfere with charging.Where are you based in the world crea2k?

            Comment


            • #7
              If you checkout the lines coming to and from pmic, tristar on the schematic you'll see what sort of lines there are. im based in the U.K., lincolnshire
              Last edited by crea2k; 01-11-2018, 10:17 PM.

              Comment


              • #8
                You're right to think that this could be tigris--Tigris's job is to get a thumbs up from the usb interface checker--tristar--and to ALSO get a thumbs up from the battery via gas gauge and sense lines. If all checks out then charging is enabled. Get a schematic for iPad Air and for iPhone 6. Trace the 5v0 usb line to see where it goes in both. You'll find many similarities, and some differences. In the iPhone 6 the "charging function" has been split out to a new chip, tigris, from its ancestral location in all earlier devices. Where is the equivalent function of tigris in the iPad Air?

                Your mini 4 will be very similar to the Air charging system.

                Your overall problem is probably one of battery current sensing---the phone disables the 'thumbs up' for charging when the device consumes more current once it powers on. If this was a phone, you'd change tigris, but in the Airs and minis, there is no tigris and changing the equivalent chip is "a whole big thing" When I troubleshoot these I focus on figuring out if there is a way to convince the iPad that current sensing is normal and that usually involves jumping across the batt-main mosfets. By looking at the 6, it seems that some part of tigris's ability to understand current sensing comes from the q1403 in a way that I'm not sure of. I do know that I've solved "state specific charging issues" by jumping the mosfet at times that changing tigris and confirming my battery data lines were intact all the way up to pmic.

                It is also unclear what the relationship is between tristar and battery. There is no direct relationship. However, we know that experimentally that changing tristar alone can make some devices that charge fine unless it has a stone dead battery suddenly be able to charge that stone dead battery. This must involve some kind of battery data communication between the CPU or PMIC and tristar because tristar does not talk to battery data lines directly. That battery data communication may come through tigris, or direct to CPU/PMIC from battery. So the part of your problem that tristar no long detects usb after boot should of course be ruled out with new tristar, but it sounds like all of this is likely battery data lines and battery current sensing fuckery. There aren't a lot of places that these can fail outside of the PMIC, but definitely rule all of those out--especially battery connector.

                Comment


                • #9
                  Thanks Guys it gives me a starting place to do some investigation will post back results

                  Comment

                  Working...
                  X